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What's In PhotoMorph?

PhotoMorph is an award-winning special effects package for Windows. 
PhotoMorph allows you to combine and apply sophisticated special effects to 
video clips and bitmap images. PhotoMorph is used by professionals in the 
fields of desktop video, graphic design, multimedia production, and 
presentation graphics. PhotoMorph combines image editing, special effects, 
and digital video in one unbeatable product!



New Features in PhotoMorph 2!

Background Rendering
This new feature lets you run interactive applications like word 
processing and image editing while PhotoMorph renders images in the 
background. Its automatic! Simply iconize PhotoMorph or use Program 
Manager to switch to another application. PhotoMorph will notify you 
when it has finished.
Multiple Filters Per Clip
Each Storyboard clip can now have up to three effects. This means that
you can mix or special effects in any combination. You can accumulate 
three transition effects or you can do a triple morph.
Motion Morphing
Motion Morphing means that you can morph using AVI clips. Your 
subjects can be moving as they are morphing.
Motion Warping
Motion Warping means that you can warp any AVI clip. You can bring 
an AVI clip into the Warp Editor and stretch any moving video.
Chroma Keying
Blue Screening
Luminance Keying
These are very powerful professional effects that let you combine 
different images and lay in false backgrounds.
Alpha Channel
The Alpha Channel effect is used to create very interesting see-through
and semitransparent image effects. PhotoMorph has extensive support 
for Alpha channel effects with many different tools.
Alpha Transitions
The Alpha Channel is a very powerful mechanism for doing scene 
changes, transitions, and wipes.    Alpha Transitions are a way of 
combining the alpha channel effect with the Transition Editor.
Dynamic Video Effects
Twelve new video effects allow you to apply image filters directly to AVI
files. These filters will colorize your movies using very exotic methods.
Text Overlay
The Text Overlay feature allows you to place TrueType and PostScript 
fonts directly onto AVI files. Its great for Titling.
Color Correction
The Image menu now supports color correction of bitmaps. You can 
adjust hue, saturation, contrast and brightness of any image.



Multiple Filters Per Clip
Perhaps the trickiest feature in PhotoMorph 2 is the ability to use multiple 
filter effects in a single storyboard clip. This feature is very powerful for 
combining effects and creating new effects.    Using the new multiple filter 
interface you have can up to three filter effects and up four AVI clips or 
bitmaps. You can use filters in any combination. For instance, you can 
combine a transition with a colorize and a text overlay or you can combine 
three morphs!    

It is important to remember that the output of Filter 1 becomes the input of 
Filter 2, and the output of Filter 2 becomes the input of Filter 3.    Once you 
have placed Start and End images in the Projects Editor and selected the 
Filter Type for Filter 1, simply click on the [123] button. This will move you to 
the options for Filter 2. You then select the images you want for the Start and
End and the filter type for Filter 2. To combine Filter 2 with Filter 1 you simply
choose the selection [Filter 1] from the image list in either Start or End or 
both.    Repeat this process to add a third filter. Refer to you PhotoMorph 
manual for an example of the process.

If you wish to view the options in a different filter, simply click on the [123] 
button. This will advance by one filter and will display the selected options.



Motion Morphing

What is Motion Morphing? 
Motion Morphing is simply the morphing process applied to two different 
video clips. The difference between Motion Morphing and regular morphing 
between two still images is that there are now multiple starting images and 
multiple ending images.

How do you use the Morph/Warp Editor for morphing?
The Morph/Warp Editor has not changed much to add Motion Morphing.    
Load two AVI files into the Start and End of the Project Editor, select Morph as
the Filter Type and click on Edit.    The morphing process involves placing 
points on the Start image and adjusting them on the End image. Use the 
slider control to advance the frames.    Once you place a point on the starting
image PhotoMorph will create Smart Points on all subsequent frames.    All 
you need to do is adjust these points to match the features of your two 
images.    When you move points, PhotoMorph will apply a linear interpolation
to help you adjust them. Refer to your PhotoMorph manual for a full 
discussion of Smart Point and linear interpolation.



Motion Warping

What is Motion Warping?
Motion Warping is simply the PhotoMorph warping process applied to a single
AVI video clip.

How do you use the Morph/Warp Editor for warping?
To use motion warping simply load an AVI clip into the Start image of the 
Project Editor and select Warp as the Filter Type.    In the Warp Editor simply 
place points on the features that you wish to distort. Place points on the 
features in the Start image and stretch those points in the End image.

PhotoMorph will place points on all frames following the frame where you 
placed points. These points are called Smart Points. You can move and delete
these points as if you had created them yourself.    

Smart Points and Real Points, the points that you placed yourself, are all 
color coded for easy identification.    You can use the Point Color Tool in the 
Morph/Warp Editor to easily change the colors of the different point types.

Please refer to your manual for discussion and examples of Motion Warping 
and Smart Points.



 Color Keying
What is color keying?

Blue Screening
Chroma Keying
Luminance Keying



Alpha Channel
What are Alpha Channel images?
Alpha Channel images are regular color pictures with a mask that allows 
them to be combined with other images.

How can you see an Alpha Channel image?
PhotoMorph allows you to create, import, preview, and combine Alpha 
Channel images in ways that create amazing special effects. PhotoMorph has
an Alpha Channel Editor that lets you create the overlay mask. It also has the
Alpha Overlay Filter which combines Alpha Channel images with standard 
images and other effects.

How do you work with Alpha Channel images?
All Image menu operations, all Filter menu operations, and all Colorize 
operations work with Alpha Channel images to perform image editing, text 
overlay, colorizing effects.

It is important to know that the Alpha Overlay Filter is enabled only when a 
32-bit Alpha Channel image is in the Start or End image in the Project Editor. 



 Colorizing and Dynamic Video Effects

What is Colorizing?
The Colorizing effects in PhotoMorph allow you to apply image effects 
directly to AVI video clips. You can turn a color animation into an old 
fashioned black and white movie. You can adjust the contrast just like you 
would a television set. There are 12 different effects to choose from.

Variable and Constant Controls
PhotoMorph gives you control of how you apply these effects. You can 
gradually fade these effects in over time. You apply the effect at 30% of full 
and hold it constant across the clip, or you can apply the full effect for just a 
portion of the clip.    These parameters are found in the Options box in the 
Project editor. 

Video Editing Options
You can use the Video Editing Options tool to set where an effects begins or 
ends in a given clip. This tool is next to the Options box in the Project Editor. 
This tool is below and to the right of the Start and End image. It is only 
enabled when an AVI file is loaded to the specific window.

Colorize effects for Contrast, Noise, Trace Edges have additional controls that
allow fine tuning.    The slider bar allows you to change frames and preview 
the effect across the entire clip.    It is very similar to using the Preview tool.

Colorize effects are great when combined with other Filter effects like Alpha 
Channel, Blue Screening, and Distortions. 
See also: Filters Menu



The Transition Editor

What are Transitions?
A transition is the changing from one video clip or image to another.    A 
transition is the method or effect that you use to perform a scene change.    
Because a transition can convey a wide range of expressions it is important 
to have a wide variety of transition methods.    This is why the PhotoMorph 
Transition Editor provides more than 256,000 transition combinations. 

How do you use the Transition Editor
The Transition Editor is arranged with simple WYSIWYG (what you see is what
you get) features. There are three sections that are important: Direction 
Arrows, Faders, and Background Color. 

Direction Arrows control the transition direction and motion for Start and 
End clips.    The Start clip always fades out and the End clip fades in. Each 
arrow is a button which points in the direction that a portion of the clip will 
follow.

Faders are important effects that you can add to transitions. Alpha, Fade, 
Melt, Random, and Solid each add a unique color effect. For instance, Fade 
adds a color dissolve effect, Melt adds a luminance key effects, Random 
adds color speckles, Alpha performs a transition based on the internal Alpha
Channel provided by the Start image.    Solid is the same as not using a fader.

The Background Color option allows you to choose background colors for 
transitions. The color you choose will become the background color of the 
transition and can also modulate a particular fader control.    For instance, if 
you choose green as the background color and Random as the fader, the 
color speckles will appear green instead on random colors.
 
The Transition List on the leftmost side of the Transition Editor lists the 
names of the most commonly used transitions. To use a particular transition 
that is listed simply choose two clips and select a transition from the list.



Text Overlay or Dynamic Titling
What is Text Overlay? 
The Text Overlay feature in PhotoMorph allows titling of both video clips and 
bitmaps with TrueType and PostScript fonts. Fonts can be any of 16 million 
colors.

The Style option allows you to choose from any installed font styles and 
sizes.

The Alignment option allows you to position your text and to choose 
between left-justified, right-justified, and centered alignments

The Color option allows you to choose a font color from 16 million colors.

The Text box is where you type in the text that you wish to appear. The text 
overlay will update the image with each keystroke. text is limited to one line 
of text.

Note: lossy video compression methods like Indeo can make text look very 
jagged after it is output to an AVI file.    You can minimize this problem be 
either choosing black or white as the text color or by simply choosing 
Cinepak as the compression type.



Quick Directions

PhotoMorph comes with many sample projects that you can morph in just 
seconds! 

Open the Project Editor from the Tools menu.    Use the Load Project icon (the 
leftmost icon in the tool bar) to load a PhotoMorph project (any file with the 
extension PMP).    Click on Create Animation to render the movie, then 
choose AVI Player from the Tools menu.    Load the movie and click Play.



System Requirements

Minimum System Configuration
o Windows 3.1
o 386SX CPU
o 4 MB of RAM
o 4 MB of disk space
o A mouse or equivalent pointing device

Minimum Professional System
o 486/25
o 8 MB of RAM
o 30 MB of Disk Space
o Local Bus Video Card 



Load Project

The Load Project dialog box imports PhotoMorph Project files with the PMP 
extension.



Save Project

The Save Project dialog box saves an existing PhotoMorph project to a user-
specified project file. A project file, or PMP file contains only the name and 
location of animage file and does not contain the image itself.    



Start Image

The Start Image dialog loads an image into the Start window of the Project 
Editor.    This image will be used as the starting image of a filter effect such 
as morphing or chroma keying. 



End Image

The End Image dialog loads an image into the End window of the Project 
Editor.    This image will be used as the end image of a filter effect such as 
morphing or blue screening.



The Project Editor

The Project Editor is the main control window for PhotoMorph.    In the Project 
Editor, the user can load Start and End images for animations; choose 
different types of filter effects; open the Filter Editor; chain videos together 
with the Storyboard; set animation parameters; open the Preview Window; 
and open the AVI Player.

Clip Options
The Basic Tools
The Video Editing Options Tool
Multiple Filters Per Clip



The Preview Tool

The Preview Window previews the current filter effects in the currently 
selected Storyboard clip.    It is very useful for previewing part of an 
animation before creating a final animation.    The preview tool can be used 
to save individual frames to files or to copy them to new image windows.



The AVI Player Tool

The AVI player allows you to play your AVI animations from within 
PhotoMorph.    VCR-like controls are provided for play, rewind, fast forward, 
and single-stepping back or forward.

The Load AVI icon in the AVI Player loads a Video For Windows movie in the 
AVI format. The AutoPlay icon will load a sequence of AVI video clips, and 
can be directed to play a group of AVI clips any number of times in any 
sequence. This is a very powerful tool for presentations. The Close icon will 
close and release a currently loaded AVI clip. This is useful if you are running 
the DOS Share utility or if you wish to free memory.



Colors Menu

Use the Colors Menu to convert the color configuration of bitmapped images 
(i.e., monochrome, 8-bit color, grayscale, 24-bit color, etc.).    Advanced 
image processing techniques such as dithering and optimized cut color 
reduction are available. The dithering options are specified in the 
File/Settings menu.



Help

The Help icon displays this Windows Help file.    Context-sensitive help may 
be displayed within each PhotoMorph window by pointing at the feature in 
question.



PhotoMorph Menus

File Menu
Edit Menu
Capture Menu
Colors Menu
Image Menu
Filters Menu
Tools Menu
Window Menu
Help Menu



File Menu

The PhotoMorph File menu has two main sections: Image and Project.
Use the File/Image menu for standard operations on image files, such as 
loading, closing, saving, and renaming.    You can use the Image/Save As... 
option to perform color reduction and compression.
Use the File/Project menu for operations on PhotoMorph projects, such as 
loading a new project, loading an existing project, saving a project, and 
renaming a project.



Edit Menu

The Edit menu provides standard file editing operations such as cutting, 
copying, pasting, and deleting.    Use Undo to reverse an Image or Colors 
operation.    Note that the Edit menu operates only on image files, not on 
PhotoMorph projects or AVI video clips.



Capture Menu

The Capture menu allows the user to create screen captured images.    
Choose a region from the list:    Active Window, Active Application, Entire 
Screen, User-Defined Rectangle, or Window Under Mouse.    Use Set Options 
to direct the screen capture to a file, new window, or the Clipboard, to 
specify the window area to capture, and to set the hot key (default = F11).

To use Screen Capture, Open PhotoMorph and set the Capture options, 
minimize PhotoMorph, load the program whose screen you wish to capture, 
and press the hot key to initiate the capture.



Image Menu

The Image menu provides image manipulation, editing operations, and color 
correction.    

Invert Image - Inverts the colors producing a negative image.
Flip and Mirror - Changes the orientation of an image.
Crop and Scale - Changes the size of an image.
Rotate - Rotates an image by 1 degree intervals.
Frame/Caption - Adds a color border and/or color text.
Tile - Creates a matrix pattern of an image, 1x3, 2x2, etc
Mask - Overlays a pre-defined shape over image
Contrast/Brightness,
Hue/Saturation - Adjusts the color components of an image.



Tools Menu

The Tools menu provides access to the Project Editor, Preview Window, and 
AVI Player.    Selection of any item in the menu will toggle the display of the 
desired window.

Project Editor
Preview Window
AVI Player



Window Menu

The Window menu provides options for managing PhotoMorph windows.    Tile
arranges all open image windows such that all windows are visible and none 
are overlapping.    Cascade stacks the open image windows one on top of 
another, so that each title bar is visible above the next one in the stack.    
Close All closes all open windows.    Arrange Icons lines up any iconized 
windows at the bottom of the screen.    There is a list of all open windows at 
the bottom of the menu; click on one to bring it to the front.



Help Menu

The Help menu gives you access to online help and other information.    Index
gives a list of PhotoMorph topics available through online Help.    Using Help 
gives you information on using the hyperlink Help system.    System Info 
displays complete information about the current state of your system.    Use 
this for diagnosis of any problems and have this information available if you 
call North Coast Software technical support.    About PhotoMorph presents a 
message about the program and North Coast Software.



Filter Editor

The Filter Editors give are the tools that work with a specific special 
effect within a PhotoMorph clip.

Morph and Warp Editor
Transition Editor
Colorize Editor
Distortions Editor
Overlay Editor (contains Color Key Effects, Alpha Overlay, and text 

Overlay)
Alpha Channel Editor
Text Overlay Editor



The Morph and Warp Editor

The Filter Editor for morph and warp clips is accessed by clicking the Edit... 
button or the right arrow in the Project Editor.    It allows the user to place 
control points on the Start and End images to specify the action which should
occur during the animation.    Points can be placed, moved, or deleted with 
the tool bars.

See Also: Motion Morphing, Motion Warping



Clips

A clip is an animation or a section of an animation.    Clips can be chained 
together via the Storyboard. A clip must contain at least one image.



Animation Parameters

Set animation parameters in the Project Editor.    Click on the Animation 
Parameters icon to toggle the display.    Use the edit boxes to set Speed, 
Compression type, Output File type and settings, and animation Quality.

 Refer to your PhotoMorph manual for a discussion of each of these 
parameters.



Filter Types
A Filter Type is basic category of special effect within PhotoMorph. These 
filter types are found in the Project Editor and are used to apply an effect 
within a Storyboard clip. A filter will work with both video clips and bitmap 
images. Some filters work with two images while others work with only one. 

To choose a filter, select from the Filter Type list box in the Project Editor. 
Select one or two images for the Start and End image, depending on the 
filter, and click on Edit.

Available Filter Types:
Morph
Warp
Transition
Colorize
Distort
Overlay (contains Color Keying, Alpha Channel, and Text Overlay)



Filters

Image Filters may be applied to color bitmap images to add more flavor and 
personality.    Some filters are subtle in the actions, others will substantially 
change an image's appearance. If more of an effect is desired, the filter may 
be applied repeatedly to an image.

The following list of filters is available: Contrast, Sharpen, Sharpen 
Edges, Despeckle, Emboss, Blur, Median, Trace, Noise, 
Maximum, Minimum, Old Movie.

These same affects may be applied to AVI video clips by using the Colorize 
filter.



Clip Options

These parameters provide additional control when applying an effect to a 
clip..

Filter Percentage
Variable - choosing this option causes a filter to affect a clip gradually 

over time. The effect starts at 0% and increases to 100% at the frame 
specified with the Video Editing Options tool.

Constant - choosing this option causes a filter's effect to stay at a 
constant level throughout the clip.
Color Shift

The Color Shift control determines how fast the color shift from the first
image to the second image.    The default is linear.
Movement Speed

The Movement Speed control is used to set the speed at which an 
effect occurs. The default is a linear transition speed. This control can create 
a fast start and a slow ending or a slow start and fast ending. This is great for
creating more natural movements.

Alpha Masks
This list box allows you to select an Alpha Channel mask to apply to a 

clip. 



Distortion Editor

These 22 Video Distortion effects can be applied to bitmaps and AVI clips.    
Low, Medium, and High quality can be applied to these effects. Use the 
Animation Parameters icon in the Project Editor to set the quality.    Low 
quality is very quick to render, high quality takes longer to render but gives 
substantially more image resolution.      Effects denoted with (F) require a 
floating point coprocessor.



Alpha Channel Editor

The Alpha Channel Editor

How to use the Alpha Channel Editor to create 32-bit images.



The Blue Screen Editor

To use the Blue Screen Editor you must have a Starting image that has blue 
in it.    The editor will let you adjust the range of blue color which wil become 
transparent to the End image. That is, the End image will show through 
where the Start image is blue.

The Lightness control lets you brightest shade of blue, or the upper limit of 
the color range. Darkness is the control for the darkest shade of blue to 
pass through. Shadow is used to pass through a blue screen shadow to the 
final image. This control is only pertinent of your blue screen image has a 
shadow on the blue part of the image.



Chroma Key Editor

The Chroma Key Editor will let you select a range of color in the Start image 
which becomes transparent to the End image. The range of color is 
determined by the Chroma, Tolerance, and Darkness controls. You can 
sample a color from the Start image using the Eyedropper tool or you can 
select a color using the Chroma tool. The Tolerance and Darkness tools 
will let you controland decrease the range of colors.



Luminance Key Editor

The Luminance Key Editor will let you select a range of lminance values, or 
brightness    in the Start image which becomes transparent to the End image.
The range of luminance values is determined by the Maximum and 
Minimum controls. You can sample a color from the Start image using the 
Eyedropper tool and adjust the range of colors using the Minimum and 
Maximum tools. Use can use the left mouse key to select the minimum color 
and the right mouse key to select the maximum color.



The Basic PhotoMorph Tools

Load Project
Save Project
Start Image
End Image
Project Editor Tool
Preview Window Tool
AVI Player Tool



The Video Editing Options

Setting In Points and Out Points on Video Clips. You can use this tool to 
establish the frames within an AVI clip that an effect starts and ends on. 
These are respectively called the in point and the out point.    This tool is 
extremely useful and can be used to perform simple video editing tasks.    
These options also let you set the sampling method.    By Time matches the 
sampling to the amount of time the clip runs for.    By Frames matches the 
sampling to the number of frames in your clip.    Whole Clip matches the 
output to match the input as closely as possible.



Common Questions From PhotoMorph Users

Why do the pictures look washed out and have few colors?
Check to make sure that you have the correct driver installed in your video 
card. Windows defaults to only 16 colors if it does not have a video card 
driver.    To check your video card driver, choose Windows Setup in the Main 
group. 

How can I speed up the playback of AVI files?
Output to FLC instead of AVI. Use the Media Player found in the Accessories 
Group to play the FLC file. Also, some compression schemes play back faster 
than others. Cinepak is faster than Indeo but FLC is fastest.

How can I get full screen playback of animations?
The easiest way to get full screen playback is to use the Media Player to load
an AVI or FLC file, use Options to select Full Screen. 



PhotoMorph on CD-ROM

For multimedia users with CD-ROM drives, we've got a great offer for you! 
Upgrade to the CD-ROM version of PhotoMorph. Here's what you get:

70 AVI morph movie clips - more than 300 MB of files!
40 different projects for you to morph
large resolution images for full screen animations
The AutoDesk ANIPLAY utility for super fast playback of FLC animations

under DOS
And much more!

Call (800) 274-9674 for more information..



The Warp Editor

See also: Motion Warping
See also: Morph Editor



The Overlay Editor

Blue Screening
Chroma Keying
Luminance Keying
Alpha Channel Overlay
Text Overlay




